إنتقال للمحتوى

  • تسجيل الدخول عبر الفيس بوك تسجيل الدخول عبر تويتر Log In with LinkedIn Log In with Google      تسجيل دخول    
  • إنشاء حساب

صورة
- - - - -

مشكلة oracle not available حلت (internal/oracle


6 رد (ردود) على هذا الموضوع

#1 mahmoud20107

mahmoud20107

    مشترك

  • الأعضــاء
  • 56 مشاركة

تاريخ المشاركة 04 March 2004 - 09:52 AM

اخواني الاعزاء
بالفعل بدات تحدث معي المفاجات من جديد
حيث الحمدالله قمت بتنزيل الاوركل 8i
والدفلوبر 6
وتم الاتصال والغريبة انه كل ما اعمل restart
وعندما ادخل على sql
وجدت الجملة التالية oracle not available

وضعت اسم المستخدم internal
كلمة الدخول oracle
>startup open ;
وانحلت المشكلة ولكن لا بد من هذه الحركة عند كل دخول


ولكن سؤالي هل listener يعني ما بشتغل في التحميل بالاكس بي
علما انه شغال من ال services

ممكن تفسير وحل للمشكلة ان امكن
--------------------------------------------------------------------

وهذا نص المشكلة وحلها المؤقت لمن اراد الاستفادة ونتمنى ايجاد السبب


ERROR:
ORA-01034: ORACLE not available

لحضة الدخول internal/oracle
Connected to an idle instance.

SQL> startup open ;
ORACLE instance started.

Total System Global Area 127203276 bytes
Fixed Size 65484 bytes
Variable Size 25792512 bytes
Database Buffers 101271552 bytes
Redo Buffers 73728 bytes
Database mounted.
Database opened.

----
اخوكم
محمود

تم التعديل بواسطة mahmoud20107, 04 March 2004 - 09:55 AM.


#2 عمر باعقيل

عمر باعقيل

    مشرف سابق وعضو مميز

  • المجموعة الماسية
  • 543 مشاركة

تاريخ المشاركة 04 March 2004 - 10:20 AM

السلام عليكم ورحمة الله وبركاته

اخي mahmoud20107 , لم تذكر لنا ماهو نظام التشغيل الموجود لديك مع ان اعتقد انه

ويندوز إكس بي , حيث انني قد واجهت هذه المشكله عندما قمت بتركيب الاوراكل 8i في ويندوز اكس بي

طبعا وبناء على ماذكرته شركة أوراكل فان هذا الاصدار أوراكل 8i لايتوافق مع ويندوز اكس بي

لذلك تحدث لك هذه المشكله والله اعلم .

جرب يااخي بأن تقوم بتغيير قيمة المفتاح التالي في الرجستري ORA_ORACLE_AUTOSTART

وهذا المفتاح موجود ضمن مفاتيح الاوراكل هوم والخاص بقاعدة البيانات فلو كانت قيمته FALSE

فقم بتغييرها الى TRUE واعد تشغيل الجهاز ولربما ستعمل عندك قاعدة البيانات تلقائيا أما بخصوص الLISTNER

فأكيد هو شغال لانه الطريقه التى انت تعملها لتشغيل قاعدة البيانات فقط وليس لتشغيل ال LISTNER

ايضا لاتحتاج يااخي بأن تكتب STARTUP OPEN كفايه STARTUP .

عمر باعقيل
كندا - مونتريال
baaqeel@araboug.org
سبحان الله وبحمده , سبحان الله العظيم

#3 mahmoud20107

mahmoud20107

    مشترك

  • الأعضــاء
  • 56 مشاركة

تاريخ المشاركة 05 March 2004 - 07:45 AM

اخي عمر
الف شكر لك على هذه المعلومات القيمة وهيك انت طمنتني انه بس في مشكلة مع الوندوز اكس بي فقط
انا عملت سكربت ببدا التشغيل يقوم بالخطوات السابقة
بالنسبة مفتاح الريجستري
لقد قمت بالحويل من
true to false
لكن لم يحدث اي تغير
ولكن الف شكر لك على المعلومات مجددا والله يبارك فيك وفي كل الاخوان



اخوك
محمود

#4 هانى سند

هانى سند

    مشرف سابق وعضو مميز

  • المجموعة الماسية
  • 743 مشاركة

تاريخ المشاركة 06 March 2004 - 10:24 AM

هي المشكلة يا اخ محمود تقريبا انه مش بيحتفظ بباث p_file الخاص بالاوراكل بارمترز
لاني انا حصل معايا نفس المشكلة وكنت بعمل open للدااتبيز من dba studio بس كان كل مرة بيطلب الباث ده
و في كي في الريجستري خاص بالباث ده
جرب تغيره و خليه الباث للفايل init.oraالموجود في
oracle /admin/p_file
و جرب
علي فكر دلوقتي علي جهاز تاني بس برضه اكس بي بيعمل حاجات غريبة
بيقولي مو ف ي listener
لما كونكت علي dba studio
مع انه بيكونكت من sql plus and developer
ربنا يستر
:)

#5 عبدالله ندا

عبدالله ندا

    مشرف سابق وعضو مميز

  • المجموعة الماسية
  • 1,017 مشاركة
  • الاسم الأول:عبدالله
  • اسم العائلة:ندا
  • البـلـد: Country Flag
  • المنصب الحالي:Technical Applications Manager

تاريخ المشاركة 06 March 2004 - 01:00 PM

هلا اخواني
بالنسبه لموضوع اوراكل نوت افايبول علي ويندوز اكس بي و 2000 سيرفر و ادفانسد سيرفر
فهذه بجاية موجوده في بعض اصدارات الاوراكل
حلها
ازهل الي ملف sqlnet.ora
ستجد قيمة اسمها nts اجعلها NONE حروف كبيره مهم جدا
و اعمل ريستارت ستحل المشكله لو هي نفس البجاية
شكرا لكم مع تمنياتي بالتوفيق

في زمننا هذا .........................
ليس هناك قلب ناصع البياض ...
ولا قلب قاتم السواد ...
ولكن دائما
BLACK&WHITE

 

مع تحياتي
عبدالله ندا

http://anada.4shared.com

abdallahnada@hotmail.com 


#6 هانى سند

هانى سند

    مشرف سابق وعضو مميز

  • المجموعة الماسية
  • 743 مشاركة

تاريخ المشاركة 11 March 2004 - 02:38 PM

علي فكرة اخ بلاك انج وايت
هي غالبا مو نفس البجاية عشان انا غيرت الnts و سويتها NONE و كابيتال والله ):- بس مو نفع
و لسه مستني مشكلة الليستنر

#7 120000078

120000078

    عضو

  • الأعضــاء
  • 8 مشاركة

تاريخ المشاركة 24 April 2004 - 12:38 AM

يا شباب عندي win xp وعلية أوراكا 8I وما يعمل ؤخىىثؤف بسبب هذة الرسالة
ora-12560: tns خطأ في مهيء البروتوكول
.