إنتقال للمحتوى

  • تسجيل الدخول عبر الفيس بوك تسجيل الدخول عبر تويتر Log In with LinkedIn Log In with Google      تسجيل دخول    
  • إنشاء حساب

صورة
- - - - -

مشكلة فى Lov


3 رد (ردود) على هذا الموضوع

#1 ahmed elkyal

ahmed elkyal

    مشترك

  • الأعضــاء
  • 61 مشاركة
  • البـلـد: Country Flag

تاريخ المشاركة 26 July 2012 - 04:19 PM

السلام عليكم ورحمة الله
قمت بعمل lov بين deptno - deptname ولا يوجد مشكله الا عند الاستعلام بعد الحفظ فيظهر فقط deptno ولا يظهر deptname مع العلم ان deptname فى خصائصه
database = no
برجاء المساعده

#2 tininana136

tininana136

    عضو

  • الأعضــاء
  • 2 مشاركة
  • البـلـد: Country Flag

تاريخ المشاركة 26 July 2012 - 11:07 PM

السلام عليكم ورحمة الله
قمت بعمل lov بين deptno - deptname ولا يوجد مشكله الا عند الاستعلام بعد الحفظ فيظهر فقط deptno ولا يظهر deptname مع العلم ان deptname فى خصائصه
database = no
برجاء المساعده


طيب ليه خاصيةno جربها ب yes



#3 elbanna2008

elbanna2008

    مشترك

  • الأعضــاء
  • 68 مشاركة
  • البـلـد: Country Flag

تاريخ المشاركة 27 July 2012 - 03:07 AM

اولا لو الفيلد بتاع الdept name عباره عن database item
فخليه الداتا بيز = yes واحفظ ولما تيجي تستعلم هيرجع الاسم والرقم عادي
ثانيا لو الفيلد بتاع ال dept name عباره عن display item وملوش علاقه بالداتا بيز يبقى
هتيجي على الفيلد dept no وتعمل تريجر post change تكتب فيه
[left]
[/left]
[left]if :dept_no is not null then[/left]
[left]select dept_name into :dept_name [/left]
[left]from dept [/left]
[left]where dept_no = :dept_no[/left]



بتقول لو ال dept_no مش فاضى هات اسم الاداره وحطها فى dept_name لما ال dept no بيساوي نفس الرقم اللى على الشاشه

يارب تكون سهله وواضحه



#4 ahmed elkyal

ahmed elkyal

    مشترك

  • الأعضــاء
  • 61 مشاركة
  • البـلـد: Country Flag

تاريخ المشاركة 27 July 2012 - 04:20 AM

شكرا جزاك الله كل خير اشتغل الكود معايا تمام